Product Page Errors
Incident Report for Purse IO
Resolved
Product pages are working properly.
Posted about 1 month ago. Jun 15, 2019 - 07:10 UTC
Investigating
We are experiencing more errors with loading product pages on Purse.
Posted about 1 month ago. Jun 15, 2019 - 05:00 UTC
This incident affected: Shopping.