Delayed Bitcoin (BTC) withdrawals
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 18:26 UTC
Update
We are continuing to investigate this issue.
Posted Dec 21, 2020 - 05:35 UTC
Investigating
we are investigating delays in processing BTC withdrawals
Posted Dec 21, 2020 - 00:15 UTC
This incident affected: BTC Withdraws.