Search is down
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 20, 2018 - 18:59 UTC
Investigating
We are investigating why search is not returning results. In the meantime, we recommend import an Amazon wish list to add items to cart.

Or check out this sweet Chrome Extension made by a community member, which allows you to add items to Purse cart from Amazon: https://chrome.google.com/webstore/detail/buy-with-bitcoin/kigloeblmladdhiffedaloaikkodgbpj?hl=en

We're working to restore service asap.
Posted 4 months ago. Aug 22, 2018 - 23:17 UTC
This incident affected: Shopping.