Product Page Errors
Incident Report for Purse IO
Resolved
Product pages are now working correctly.
Posted 3 months ago. Jun 12, 2019 - 18:30 UTC
Investigating
We're seeing intermittent errors on some product pages. We're investigating the issue and hope to have it resolved quickly.
Posted 3 months ago. Jun 12, 2019 - 17:30 UTC
This incident affected: Shopping.