Site Down
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Apr 03, 2020 - 04:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2020 - 03:12 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 03, 2020 - 02:34 UTC
This incident affected: Earning and Shopping.