BTC withdraws are failing/delayed
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 23:37 UTC
Investigating
We are working on an issue causing some Bitcoin (BTC) withdrawals to fail. Once back up an running, those withdrawals will be cancelled and you can try again.
Posted Dec 14, 2021 - 18:28 UTC
This incident affected: BTC Withdraws.