Site is temporarily down
Incident Report for Purse IO
Resolved
All systems are running smoothly!
Posted 7 days ago. Dec 04, 2018 - 00:47 UTC
Update
All systems are running smoothly!
Posted 7 days ago. Dec 04, 2018 - 00:46 UTC
Identified
Hang in there! We've encountered some turbulence and will be back up and running as soon as possible.
Posted 7 days ago. Dec 04, 2018 - 00:07 UTC
This incident affected: Earning, Shopping, Mobile Apps, Email Delivery, BTC Deposit, BTC Withdraws, BCH Deposits, and BCH Withdraws.