BTC withdrawals delayed
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 20:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2020 - 17:37 UTC
This incident affected: BTC Withdraws.