We have received reports that some users cannot access the site.
Incident Report for Purse IO
Resolved
This issue has been resolved. If you are still experiencing the problem you need to hard refresh the site (see https://browserhow.com/how-to-hard-refresh-and-reload-a-page-in-chrome-computer/ for how to do that).

This issue only affected certain geolocations due to a caching issue with outdated frontend assets.
Posted Mar 14, 2021 - 18:45 UTC
Investigating
some users are reported the site is not functioning for them. Our site appears to be working fine though so this seems to be an intermittent problem. we are investigating
Posted Mar 14, 2021 - 16:52 UTC
This incident affected: Earning, Shopping, and Authentication.