BCH failed deposits/withdraws
Incident Report for Purse IO
Resolved
We have corrected the BCH wallet issue. all pending deposits and withdraws have been processed. Please let support know if you still have a pending withdraw.
Posted Nov 30, 2020 - 01:15 UTC
Investigating
We are investigating an issue where some withdraws/deposits are not registering. your funds are safe.
Posted Nov 29, 2020 - 16:33 UTC
This incident affected: BCH Deposits and BCH Withdraws.