Withdraws Offline
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted 24 days ago. Oct 25, 2018 - 15:20 UTC
Identified
Withdraws are still disabled while we are performing some system upgrades. We apologize that is taking longer than we originally anticipated. Some users may see incorrect balances reported in their wallet during this time. We are actively working on the issue and everything will be rectified shortly. All funds are secure and will be available for withdraw soon as possible.
Posted 24 days ago. Oct 25, 2018 - 03:06 UTC