New orders are taking longer than expected to appear on orderbook
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Jun 01, 2021 - 22:59 UTC
Investigating
We are currently investigating this issue.
Posted Jun 01, 2021 - 19:31 UTC
This incident affected: Shopping.