BTC withdrawals stuck
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 17:51 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 21, 2021 - 06:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2021 - 06:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2021 - 05:55 UTC
This incident affected: BTC Withdraws.