Shopping Cart and searches down
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 08:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2019 - 02:15 UTC
Investigating
We are currently investigating this issue.
Posted Nov 19, 2019 - 01:43 UTC
This incident affected: Shopping.