Search is down
Incident Report for Purse IO
Resolved
Determined the cause and search is now operational again.
Posted Feb 22, 2019 - 17:12 PST
Identified
Due to a change on Amazon, our search functionality is temporarily down. Our devs are on the case.

To fill your cart with Amazon items, try using our Chrome Extension:
https://chrome.google.com/webstore/detail/purse-shop-with-bitcoin-b/amdginnpaflghjbbdkfenpekaeifnpee?hl=en
Posted Feb 22, 2019 - 10:49 PST
This incident affected: Shopping.