Delayed BTC withdrawals
Incident Report for Purse IO
Resolved
Bitcoin withdrawals are now functional. all failed withdrawals have been processed.
Posted Mar 13, 2021 - 18:50 PST
Update
We are continuing to investigate this issue.
Posted Mar 13, 2021 - 13:24 PST
Investigating
we are experiencing delayed Bitcoin withdrawals. if you have a withdrawal that says 'failed', know that we are working on it and it will be processed once this issue is resolved.
Posted Mar 13, 2021 - 11:47 PST
This incident affected: BTC Withdraws.