Email Deliverability substantially delayed.
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 00:51 UTC
Identified
Emails are being delayed (upwards to 12+ hours). We apologize for the delay. If you are waiting for an email, please first add [email protected] to your contacts list and check your spam folder. Stay tuned for updates to this issue.
Posted Jun 19, 2020 - 21:25 UTC
This incident affected: Email Delivery.