Some BCH withdraws still failing
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 13:49 PDT
Monitoring
We have resolved this issue but will continue monitoring. If you had a failed BCH withdrawal, then it was automatically cancelled and your funds returned to your account. you can try to withdraw again now.
Posted Apr 17, 2020 - 12:27 PDT
Identified
we're seeing more failed BCH withdraws. we are working on another solution to prevent this from happening again. If you have a failed withdraw, then we will be cancelling them automatically and you will be able to retry once a solution is in place.
Posted Apr 17, 2020 - 08:43 PDT
This incident affected: BCH Withdraws.