Product Pages and Wishlist issues
Incident Report for Purse IO
Resolved
Product pages and wishlists are now functional.
Posted 18 days ago. Aug 29, 2019 - 21:04 UTC
Investigating
We are currently experiencing issues with amazon product pages and wishlists loading.
Posted 18 days ago. Aug 29, 2019 - 18:31 UTC
This incident affected: Shopping.