Delayed Bitcoin (BTC) withdrawals
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Dec 05, 2020 - 19:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 05, 2020 - 07:10 UTC
This incident affected: BTC Withdraws.