Product Pages Down
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 17, 2019 - 15:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Jun 16, 2019 - 16:31 UTC
Investigating
We have an issue when loading product pages. We are currently working on a solution.
Posted about 1 month ago. Jun 15, 2019 - 19:13 UTC
This incident affected: Shopping.