Delayed BTC withdrawals
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Jan 10, 2021 - 02:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 09, 2021 - 20:45 UTC
This incident affected: BTC Withdraws.