Market volatility causing delayed withdrawals
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted May 14, 2022 - 09:38 PDT
Investigating
Due to market volatility, we are noticing delayed withdrawals and long confirmation times.
Posted May 13, 2022 - 08:23 PDT
This incident affected: BTC Withdraws.