Site Down
Incident Report for Purse IO
Resolved
This incident has been resolved.
Posted Apr 03, 2020 - 01:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2020 - 01:06 UTC
Investigating
We are currently investigating this issue.
Posted Apr 03, 2020 - 00:51 UTC
This incident affected: Earning and Shopping.